Aprenda las diferencias de Buscarv y Buscarx | Xyclos

Actualizado: 6 nov


Estructura de las funciones Buscarv y Buscarx Microsoft Excel | Xyclos

La función BUSCARV, nos ha servido muy bien durante muchos pero muchos años.


Microsoft creó una nueva función similar a BUSCARV: BUSCARX.


La ventaja de BUSCARX es que tiene más opciones para controlar las búsquedas y es más fácil establecer la columna de búsqueda y la columna de resultado de la búsqueda.


BUSCARV

En el segundo argumento debemos seleccionar todo el rango de búsqueda y en el tercer argumento de la función, debemos ingresar el número de columna del rango seleccionado, que nos va a traer el resultado de la búsqueda:

=BUSCARV(B8,Precios!$A$1:$C$7,2,0)


BUSCARX

En el segundo argumento seleccionamos la columna de búsqueda y en el tercer argumento de la función, donde debemos ingresar el rango de resultado de la búsqueda, en lugar de ingresar el número de la columna, seleccionamos la columna de resultado.


Entonces en BUSCARX solo seleccionamos las columnas: de búsqueda y de resultado para ejecutar la búsqueda.


=BUSCARX(B2,Precios!$A$1:$A$7,Precios!$B$1:$B$7,,0)


Esto es mucho más fácil, especialmente cuando se tienen listas o bases de datos con muchas columnas.


Sigo usando las dos funciones indistintamente para realizar búsquedas, pero cuando quiero controlar el modo de búsqueda. BUSCARX es la solución.


¿Porqué?

Porque BUSCARV nos devuelve el resultado de la primera coincidencia, mientras que con BUSCARX, tenemos varias opciones:


1 - Búsqueda del primero al último

-1 - Búsqueda del último al primero

2 - Búsqueda binaria (orden ascendente)

-2 - Búsqueda binaria (orden descendente


Estas dos funciones se necesita dominarlas para brindar soluciones que nos van a permitir realizar mejores análisis de información.


No espere más y aprenda a usarlas en nuestro excelente curso online, disponible 24/7 de:




#CursosOnlineMicrosoft #Xyclos #Microsoft #CursoDeExcel #CursoPowerBI #CursosdeProject #CursoOnline #Aprendizaje #CrecimientoLaboral #MicrosoftExcel #MicrosoftWord #MicrosoftPowerPoint #MicrosoftOutlook #cursosexcel

27 visualizaciones0 comentarios